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1.0 TelQA Test Getting Started   

1.1 TelQA Web Performance Test Site  

TelQA Ltd provides a target ecommerce web application which is hosted on the web at 
www.telqa.com/gsg 
 
This site is only provided for use with the evaluation version of TelQA Test and is not suitable for   
large volume tests. If you require access to a dedicated test site for evaluating TelQA Test please 
contact TelQA Ltd.  
 
If you are using a licensed copy of TelQA Test please restrict your test to a maximum of 10 Virtual 
Users (VUs). 
 
 Please note that the TelQA Web Performance Test Site is periodically reset to remove unwanted 
data.  

1.2 Requirements  

1.2.1 Operating Systems  

Windows XP Professional SP2 + 
Windows Vista Professional + 
Windows7 Professional + 
Windows Server 2003 SP2 + 
Windows Server 2008 

1.2.2 Performance  

TelQA Test is written to utilise the features of Microsoft .NET.  The evaluation version of TelQA Test 
will run on machines which offer suitable performance levels for standard Microsoft .NET products. 

1.2.3 Memory 

TelQA Test memory requirements are dependent upon the size and type of test being executed.  
For the evaluation version of TelQA Test a minimum of 2GB RAM is recommended for Microsoft XP, 
Vista and Windows 7.  

1.2.4 Disk Space 

TelQA Test requires a minimum of 100MB for the application and initial repository. Please note that 
the results data repository has no internally specified maximum and hence the disk space 
requirements are product usage specific. 

1.2.5 Additional Requir ements 

TelQA Test reports are generated in Microsoft Word 2007 format. Viewing TelQA Test reports 
requires MS Word 2007 or a compatible document viewer.  

1.2.6 Internet Connection  

Broadband connection is required for connection to the TelQA Web Performance Test Site. 
 

http://www.telqa.com/gsg
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2.0 Product Overview  

2.1 Introduction  

TelQA Test is a Windows .NET based testing product which provides a fast, efficient and powerful 
means of testing the performance of web based applications.  
 
TelQA Test has a range of test development methods which allow comprehensive tests to be 
developed and executed by users with varying levels of programming ability. Both non-programmers 
and experienced programmers can utilise TelQA SmartScripts to simplify and speed up the process 
of test creation and modelling.  In addition, TelQA Test provides full script development capabilities 
using C# and VB.Net. 
 
Users typically capture the interactions between browsers, or other HTTP based clients, and the 
application under test. These interactions are then stored as a TelQA SmartScript or directly as C# or 
VB.Net based scripts.  Users then edit these stored scripts to allow large numbers of Virtual Users 
(VUs) to be replayed with unique identities.  
 
For specific applications where the HTTP interactions cannot be directly captured, TelQA Test 
provides facilities for the manual creation of SmartScript or CodeScript (C# or VB.Net) based VUs. 
 
This Getting Started Guide provides an easy introduction to TelQA Test deployment and test 
development. The features of TelQA Test mean that users can move from simple tests to complex 
testing strategies with minimal programming experience. More details of TelQA testing 
methodologies are provided in the TelQA Test User Manual. 
 

2.2 TelQA Test - Target Platforms and Interfaces  

2.2.1 HTTP/HTTPS Based Target Applications  

TelQA Test provides comprehensive functionality for the capture and replay of HTTP based data. 
Target applications are typically internet or intranet based applications, embedded Web Server 
hosted applications, etc. 

2.2.2 Terminal Based Target Applications  

TelQA Test provides comprehensive functionality for the capture and replay of terminal based data. 
Target applications are typically referred to as άƭŜƎŀŎȅέ ƻǊ άŎƘŀǊŀŎǘŜǊ ŎŜƭƭέ ŀǇǇƭƛŎŀǘƛƻƴǎΦ  
 
Note that this area is not covered within the Getting Started Guide ς download the TelQA "How to 
Test Terminal-based Applications" guide for more details. 

2.2.3 Extending TelQA Test Functionality  

The ability to extend TelQA Test through SmartScript Extensions, C# / VB.Net scripting or through 
user developed libraries means that TelQA Test provides a fully extensible platform for performance 
testing a wide range of target applications.  
 
Note that this area is not covered within the Getting Started Guide ς see the TelQA User Manual for 
more details. 
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2.3 TelQA Test - Operation and Architecture  

Performance testing a web based application typically involves applying a defined system load using 
ǘƘŜ ŎƻƴŎŜǇǘ ƻŦ ά±ƛǊǘǳŀƭ ¦ǎŜǊǎέ ό±¦ǎύΦ By monitoring a combination of hardware and software 
performance parameters whilst this VU based load is applied, the overall performance of the 
application and its host environment can be assessed.  
 
By creating VUs for each of the anticipated user types, a realistic load can be created by applying 
varying numbers and types of VUs to the target application. By providing each VU with a unique 
identity, the application under test is operating as intended and hence the results of the 
performance test can be used to determine the anticipated performance within production 
environments. 
 
The results of a system load test may include page download times, transaction response times, 
response codes, etc. These results can be analysed in combination with hardware performance 
measures (processor time, memory usage, etc) to determine whether the application under test 
meets the specified performance criteria.   
 
 

3.0 Installation and Configuration 
Follow the download instructions for the current TelQA Test evaluation on the TelQA website. Run 
the self-extracting zip file TelQATestvxx.exe to unpack the setup files. 
 
Start the installation by running the setup.exe file. 
 

3.1 Pre-Configured Repository  

There is a downloadable TelQA Test repository which contains the tests and scripts which are 
developed as part of the TelQA Test Getting Started Guide.  Follow the instructions on the website to 
download and install the repository. 
 

4.0 Test Methodology  

4.1 Test Creation with TelQA Test  

The stages of creating a Test are: 
1. Define and record individual User types as scripts 
2. Modify individual user scripts to allow for multiple Virtual User (VUs) playback 
3. Define and add VU based performance monitoring  
4. Define and add target server performance monitoring   
5. Define and create the performance test 
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5.0 Getting Started Guide - Examples Overview  
The TelQA Test Getting Started Guide uses four examples to provide a quick introduction to TelQA 
Test. Each example builds on the last to show how the interactions from different website user types 
are captured, modelled and replayed as part of a realistic performance test.  
 
The first three examples capture the interactions of each of three individual website user types. 
These interactions are then modified to allow them to be replayed as one or more individual Virtual 
Users (VUs).  
 
The final example produces a test which uses two of the website user types to provide a website 
load, whilst monitoring the time required for users to check their account details. 
    
During each test, performance data is collected and stored for post test analysis. Note that the 
TelQA Test site restricts the collection of target server performance data and hence the examples 
simulate the collection of server performance data by collecting performance data from the local 
machine. 
 
At the end of the examples you will be able to: 
 

 Capture HTTP interactions for specific user  types 

 Model captured data to create individual VUs 

 Verify the correct VU modelling by replaying an individual VU 

 Create performance monitoring collectors for both hardware and software  

 Replay created VUs as part of a test 

 Monitor performance data during a test 

 Analyse test results 

 Produce a report 

 Create and run distributed test 
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6.0 Example 1  
This example demonstrates how to create a VU which randomly browses one of four recorded web 
pages.  The VU first opens the website home page and then continuously browses through the four 
target web pages with random delays between each page. 
The steps are: 

1. Record a Browsing User 
2. Model Browsing User to allow random page browsing 
3. Create performance monitor for load machine CPU 
4. Create a test in which 10 Browsing Users are applied as the site load 

 

6.1 Recording the Browsing User  

If not already open, open the Project window using View>Project. 
Right click the SmartScripts node of the project tree. 
Select the Record Script option. 
 

 
 
9ƴǘŜǊ ά.ǊƻǿǎƛƴƎ¦ǎŜǊάŀǎ the SmartScript Name. 
Ensure that both Delete cookies and Clear cache are ticked. 
Leave the other settings as default and click OK. 
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The recording browser window will open. 
 

 
 
Enter  http://www.telqa.com/GSG as the URL. The home page of the test site is shown below. 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

http://www.telqa.com/GSG
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Select the Abbey Photographs section by clicking the  button. The following 
page will be displayed: 

 
 

Select page 2 of the Abbey Photographs using the number links  located either 
above or below the photographs. 
 
Using the number links select page 3 of the Abbey Photographs. 
Using the number links select page 4 of the Abbey Photographs. 
Page 4 of the Abbey Photographs section is shown below: 
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End the recording session by pressing the  button in the TelQA Test Recorder control dialog 
(shown below): 

 
 
 
 

The Browsing User SmartScript will now be displayed: 
 

 
 
Highlight the TelQA HTTP Performance Test Site :: Home step 
 
In the Web Page Properties panel, enter the Page Think Time as 5 seconds: 
 

 
 
Do the same for the TelQA HTTP Performance Test Site :: Abbey Photographs [1], [2], [3] & [4] 
steps. 
 
Replay the script using the Script Run toolbar button   
 After the Script run has completed, right-click the Result View node and select Open Result View 
from the menu. 
 

 
 
 
 
 
Check that the Event Log does not contain errors. Errors are displayed in red. The contents of the log 
should be similar to the example below (with different dates). 
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Close the Script Run tab and Results View tab. 

 

6.2 Modelling  the Browsing User  

The Browser User modelling is designed to allow the random selection of one of the four pages 
visited as part of the capture. 
 
A variable is created which can have a random value between 0 and 3. To change the value of the 
ǾŀǊƛŀōƭŜ όǘƻ ŀƴƻǘƘŜǊ ǊŀƴŘƻƳ ƴǳƳōŜǊ ōŜǘǿŜŜƴ л ŀƴŘ оύ ǘƘŜ ǾŀǊƛŀōƭŜ ƛǎ άǎǘŜǇǇŜŘέ ǿƛǘƘƛƴ ǘƘŜ 
SmartScript. 
 
A Switch statement is added to the SmartScript which uses the value of the random variable to 
άǎǿƛǘŎƘέ ōŜǘǿŜŜƴ ǘƘŜ ŀǾŀƛƭŀōƭŜ ǇŀƎŜǎΦ bƻǘŜ ǘƘŀǘ ǘƘŜ {ǿƛǘŎƘ ǎǘŀǘŜƳŜƴǘ ƻƴƭȅ ǎŜƭŜŎǘǎ ŀ ǎƛƴƎƭŜ ǇŀƎŜΦ 
 
This is achieved by following the steps below.  

 

6.2.1 Creating the Variable  

Open the Project Variables Editor by double clicking on the Variables node  in the 
Project Tree.   
 

 
 
Press the Add variable button .  
 
A new variable is added to the list. The variable is defined using the properties panel at the right 
hand side of the tab page. The default properties are shown below. 
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Change the Variable Name to PageSelector. 
 
Click on entry box for Variable Type and select RandomInteger.  
 

 
 
The property page will now display the fields for the RandomInteger variable type. 
Enter the following settings: 
  
Variable Scope   VU 
Minimum Value  0 
Maximum Value  3 
 
The completed property page is shown below. 
 

 
 
Save the variable (from toolbar or menu) using the  button and close the Variable Editor tab. 
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6.2.2 Adding the Switch Statement  

Using Shift + left mouse click highlight the last four SmartScript Actions in the BrowsingUser 
SmartScript. 
 

 
Right click in the highlighted area and select Insert Selection In..>Switch 
 

 
 
The added Switch statement is shown below. 
 

 
 
Ensure the Switch statement is highlighted (as above). 
 
Click within the Variable Name field of the Switch Properties panel 
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Click the select button:   
Select the PageSelector variable within the Select Variable dialog: 
  

 
 
Press OK to save selection and exit dialog. 
 
Select the Switch SmartScript Action and select Insert...>Step Variable from the right click menu as 
shown below: 
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The Step Variable action is added to the SmartScript: 
 

 
  
Click in the Step Variable Properties Variable Name field. 
 

 
 

Click the select button   
 
Select the PageSelector variable within the Select Variable dialog: 
 

 
 
 Press OK to save selection and exit dialog. 
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6.2.3 Adding the Loop  

Using Shift + left mouse click, highlight the Step Variable and Switch actions in the BrowsingUser 
SmartScript. 
 

 
 
Right click in the highlighted area and select Insert Selection In...> Loop. 
 

 
The added Loop is shown below. 
 

 
 
Ensure the Loop statement is highlighted (as above). 
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Enter the number of iteration in the Loop Properties as 10: 
 

 
 
Press Enter or click within another field to accept the change. 
¢ƘŜ ƴŀƳŜ ƻŦ ǘƘŜ [ƻƻǇ ŀŎǘƛƻƴ ƛƴ ǘƘŜ .ǊƻǿǎƛƴƎ¦ǎŜǊ {ƳŀǊǘ{ŎǊƛǇǘ ǎƘƻǳƭŘ ƘŀǾŜ ŎƘŀƴƎŜŘ ǘƻ ά[ƻƻǇ млέΦ 
 

Replay the Script using toolbar script replay button   
 
After the Script run has completed, check that 10 pages were selected by viewing the Trace 
information in the Trace tab: 
 

 
 
Note that the random variable may be set to any number between 0 and 3, so the trace may not be 
identical to the trace shown above. 
 
Open the Result View from the Script Run node in the Project Window and check that there are no 
errors in the Event Log. 
 
Close the Script Run tab and Results View tab. 

 

6.3 Adding Hardware Performance Monitoring  

This example test will demonstrate the collection of performance data by monitoring the CPU load 
of the hardware running TelQA Test. In practise performance monitoring is normally used to 
determine the performance of the target server during the test.  
 
Right click on the Data Collection Sets node of the Project Tree 
 
 Select New Data Collection Set. 
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Enter LocalMachinePerf as the Name and select Performance Counter from the type list. 
 

 
 
Press the OK button. The Performance Counter Data Collection Set Tab is displayed: 
 

 
 
Press the Add button  to display the Performance Counters Dialog (Note that the contents of the 
right-hand column may not be the same depending on the computer specification): 
 

 
 
Select the % Processor Time counter  and _Total counter from the list and then press the Add 
button. 
Press the Close button. 
The performance counter will be added to the Performance Counter Data Collection Set Tab. 
Save the Performance Counter Data Collection Set Tab and close the tab. 
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6.4 Creating the Test  

Select File>New>Test 
The New Test Wizard will be displayed. 
 

 
 
Press Next to begin the Test creation. 
9ƴǘŜǊ ά9ȄŀƳǇƭŜ мϦ ŦƻǊ ǘƘŜ ¢Ŝǎǘ bŀƳŜΦ 
Press Next. 
9ƴǘŜǊ ά.ǊƻǿǎŜǊ {ŜǉǳŜƴŎŜέ ŦƻǊ ǘƘŜ {ŜǉǳŜƴŎŜ bŀƳŜΦ 
Press Next to display the Test Scripts dialog. 

Press  to display the Select Script dialog. 
 

 
 
Select "BrowsingUser" as the Script Name and press OK. 
 
The script will be added to the list of selected scripts: 

 
 
 
 

Press Next. 
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Enter 10 as the number of VUs for the Constant Load.  
 

 
 
Press Next. 
Answer No ǘƻ ǘƘŜ ǉǳŜǎǘƛƻƴ άŘƻ ȅƻǳ ǿŀƴǘ ǘƻ ǎǇŜŎƛŦȅ ŀƴƻǘƘŜǊ ǎŜǉǳŜƴŎŜκ±¦ ǘȅǇŜΚέ 
Press Next. 
{ŜƭŜŎǘ ά[ƻŎŀƭaŀŎƘƛƴŜtŜǊŦέ ŦƻǊ ǘƘŜ 5ŀǘŀ /ƻƭƭŜŎǘƛƻƴ {ŜǘΦ 9ƴǎǳǊŜ ǘƘŀǘ άCollect all general test statisticsέ 
is ticked. 
 

 
 
Press Next to go to the Test Summary page. 
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The Test Summary should be: 
 

 
 
If the summary is different to the one shown above, press cancel and repeat section 6.4. 
If the summary is correct, press Finish to create the test. 
The Test will be added to the Project Tree. 
 

 
 

 

6.5 Running the Test  

Ensure the Example 1 test is highlighted in the Project Tree. 

Use the toolbar test run button  to start the test run. 
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The display will automatically show the Test Status panel (bottom right-hand panel) and the Agent 
Monitor panel (bottom left-hand panel).  
 

 
 
When the test is complete the Test Status panel and the Agent Monitor panel will automatically 
close. 
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6.6 Analysing Test Results  

After the test has completed the Project Tree will show a Default Result node under the run folder. 
 
Right click on the Default Result node and select Open Result View. 
 

 
 
The Results for the selected run will be opened as shown below: 
 

 
 
 
 
 



©2011 TelQA Test Getting Started Guide 

Page 22 of 88 
 

The Result Set is displayed in four tabbed panes: 
 

Result Summary Provides a summary of the test run  

Event Log Displays all events which have been recorded during the test run 

Charts Provides a graphical display of the individual results data 

Test Summary Provides a summary of the settings used for the test run 

 
LŦ ǘƘŜ {ǘŀǘǳǎ ƛǎ ƴƻǘ ά¢Ŝǎǘ ŎƻƳǇƭŜǘŜŘ ǿƛǘƘ ƴƻ ŜǊǊƻǊǎέ ƻǇŜƴ ǘƘŜ Event Log tab to check the errors. 
Remove the cause of the errors and re-run the test.  
Open the Charts tab. 
The default charts should be: 
 

 
 
Note that the data displayed in the charts may differ from those shown. 
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5ǊŀƎ ǘƘŜ ά¢ƻǘŀƭ wŜǎǇƻƴǎŜǎ ǿƛǘƘ ǎǘŀǘǳǎ нȄȄέ ŜƴǘǊȅ ŦǊƻƳ ǘƘŜ 5ŀǘŀ {ŜƭŜŎǘƻǊ ƭƛǎǘ ǘƻ ǘƘŜ /ƘŀǊǘ п ǘŀōΦ 
¢ƘŜ ά!ōƻǊǘŜŘ ±¦ǎέ ŎƘŀǊǘ ǿƛƭƭ ōŜ ǊŜǇƭŀŎŜŘΥ 
 

 
 
Select the Perf tab from the Data Selector pane. 
Drag the Processor Time entry to chart 3. 
 

  
Close the Result View tab. 
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7.0 Example 2  
This example demonstrates how to create a Virtual User which randomly searches a website with 
one of ten pre-defined search words.  The VU first opens the website home page and then searches 
using the pre-defined search words. Following a successful search the VU delays for a realistic page 
read time. Unsuccessful searches are immediately followed by the next search. 
 
Steps 

1. Record a Searching User  
2. Model Searching User to allow a VU to carry out multiple random searches 
3. Add VU performance monitoring 
4. Add performance monitor for load machine CPU created in Example 1 
5. Create a test in which 10 Searching Users are applied as the site load.  

 

7.1 Recording the Searching User  

If not already open, open the Project window using View>Project 
Right click the SmartScripts node of the project tree 
Select the Record Script option 
  

 
 
9ƴǘŜǊ ά{ŜŀǊŎƘƛƴƎ¦ǎŜǊέ ŀǎ ǘƘŜ {ƳŀǊǘ{ŎǊƛǇǘ bŀƳŜ 
Ensure that Delete Cookies and Clear Cache are ticked 
Leave the other settings as default 
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The recording browser window will open  
 

 
 
Enter  http://www.telqa.com/gsg as the URL. The home page of the test site is shown below. 
 

 
 

9ƴǘŜǊ άǊƛǾŜǊέ ƛƴ ǘƘŜ ǎŜŀǊŎƘ ōƻȄ  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

http://www.telqa.com/gsg
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Click the Search button.  The following page will be displayed (Note that the random added delay 
time may be different)  
 

 
 

End the recording session using the TelQA Test Recorder control dialog  
 
The SmartScript will now be displayed  
 

 
 
Highlight the TelQA HTTP Performance Test Site :: Home step 
In the Web Page Properties panel enter the Page Think Time as 5 seconds: 
 

 
 
Do the same for the TelQA HTTP Performance Test Site :: Search: river step 
 

Replay the Script using toolbar script replay button   
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After the Script run has completed, select open the Result View from the Script Run node in the 
Project Window. 
 

 
 
Check that the Event Log does not contain errors. Errors are displayed in red. The contents of the log 
should be similar to the example below (with different dates). 
 

 
 
Close the Script Run Tab. 

7.2 Modelling the Searching User  

The Searching User modelling uses a list of search words, some of which find pictures whilst others 
return no results. 
 

7.2.1 Creating the Variable  

Open the Project Variables Editor by double clicking on the Variables node  in the 
Project Tree.   
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Press the Add variable button .  
A new variable is added to the list. The variable is defined using the properties panel at the right 
hand side of the tab page. The default properties are shown below. 
 

  
 
Enter ά{ŜŀǊŎƘ²ƻǊŘǎέ in the Variable Name field 
/ƭƛŎƪ ƻƴ ŜƴǘǊȅ ōƻȄ ŦƻǊ ±ŀǊƛŀōƭŜ ¢ȅǇŜ ŀƴŘ ǎŜƭŜŎǘ ά[ƛǎǘέΦ ¢ƘŜ ǇǊƻǇŜǊǘȅ ǇŀƎŜ ǿƛƭƭ ƴƻǿ ŘƛǎǇƭŀȅ ǘƘŜ ŦƛŜƭŘǎ 
for the List variable type. 
Set the Variable Scope to VU. 

Click within the Values entry box and then click the enter values button   
Enter the following text within the String Collection Editor 
 

 
 
Press OK to close the dialog and save the list 
 
Set the List Variable properties to:  
Access Mode  Random 
Repeatable  False 
Unique   False 
End of Data Action Loop 
 
 
 
 
 
 
 
 
 



©2011 TelQA Test Getting Started Guide 

Page 29 of 88 
 

The completed properties are: 
 

 
 
Save the variable (from toolbar or menu) and close the Project Variables tab. 
 

7.2.2 Modifying the SmartScript  

Open the SearchingUser SmartScript by double clicking on the entry in the Project Tree 
 
Expand the second script step and highlight the search.aspx entry 
In the viewing section below the SmartScript select the Query tab the display will show: 
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wƛƎƘǘ ŎƭƛŎƪ ƻƴ ǘƘŜ άǊƛǾŜǊέ ±ŀƭǳŜ ƛƴ ǘƘŜ vǳŜǊȅ ǘŀō and Select Set value from Variable 
 

 
 
 
This will add a SetFromVariable entry within search.aspx  
 

 
 
Ensure that the SetFromVariable is selected and then click in the Variable Name entry box in the 
properties panel shown below. 
 

 
 

Click the enter values button   
Select the SearchWords variable from the Select Variable dialog 
 

 
 
Press the OK button to save the selection and close the dialog. 
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Highlight the TelQA HTTP Performance Test Site :: Search: river step. 
Right click and select Insert..>Step Variable 
 

 
 
Click in the Step Variable Properties Variable Name field. 
 

 
 

Click the select button   
 
Select the SearchWords within the Select Variable dialog 
 

 
 
Click OK 
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The Step Variable step will be added to the SmartScript 
 

 
 

7.2.3 Adding a SmartScript Loop  

Using CTRL click highlight the Step Variable and TelQA HTTP Performance Test Site :: Search: river 
steps. 
Right click on the highlighted step and select Insert Selection In...>Loop 
 

 
 
This will insert the script step into a loop 
 

 
The loop properties are defined using the properties panel at the right hand side of the tab page. 
The default properties are shown below. 
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Set the Iterations property to 10. 
 

 
 
Save the SearchingUser smartscript. 

Replay the Script using toolbar script replay button   
Check that the Trace tab shows that the search page has been accessed 10 times. Note that trace 
shows the selected search term for each access. 
 

 
 
Check the Event Log for errors. 
Close the Variables Panel by unchecking View > Variables. 
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7.3 Creating Example 2 Test  

Select File>New>Test 
The New Test Wizard will be displayed. 
 

 
 
Press Next to begin the Test creation. 
9ƴǘŜǊ ά9ȄŀƳǇƭŜ нϦ ŦƻǊ ǘƘŜ ¢Ŝǎǘ bŀƳŜΦ 
Press Next. 
9ƴǘŜǊ ά{ŜŀǊŎƘƛƴƎ {ŜǉǳŜƴŎŜέ ŦƻǊ ǘƘŜ Sequence Name. 
Press Next to display the Test Scripts dialog. 

Press  to display the Select Script dialog. 
 

 
 
Select the SearchingUser script. 
Press OK.  
The script will be added to the list of selected scripts: 
 

 
Press Next. 
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Enter 10 as the number of VUs for the Constant Load.  
 

 
 
Press Next. 
Answer No ǘƻ ǘƘŜ ǉǳŜǎǘƛƻƴ άŘƻ ȅƻǳ ǿŀƴǘ ǘƻ ǎǇŜŎƛŦȅ ŀƴƻǘƘŜǊ ǎŜǉǳŜƴŎŜκ±¦ ǘȅǇŜΚέ 
Press Next. 
{ŜƭŜŎǘ ά[ƻŎŀƭaŀŎƘƛƴŜtŜǊŦέ ŦƻǊ ǘƘŜ 5ŀǘŀ /ƻƭƭŜŎǘƛƻƴ {ŜǘΦ 9ƴǎǳǊŜ ǘƘŀǘ άCollect all general test statisticsέ 
is ticked. 
 

 
 
Press Next to go to the Test Summary page. 
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The Test Summary should be: 
 

 
 
If the summary is different to the one shown, press cancel and repeat section 7.3. 
If the summary is correct, press Finish to create the test. 
The Test will be added to the Project Tree. 
 

 
 
 
 

7.4 Running the Test  

Ensure the Example 2 test is highlighted in the Project Tree. 

Use the toolbar test run button  to start the test run. 
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The display will automatically show the Test Status panel (bottom right-hand panel) and the Agent 
Monitor panel (bottom left-hand panel).  
 

 
 
When the test is complete the Test Status panel and the Agent Monitor panel will automatically 
close. 
 
 
 

7.5 Analysing Test Results  

After the test has completed the Project Tree will show a Default Results node under the run folder. 
 
Right click on the Default Result node and select Open Result View. 
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The Results for the selected run will be opened as shown below: 
 

 
 
The Result Set is displayed in four tabbed panes: 
 

Result Summary Provides a summary of the test run  

Event Log Displays all events which have been recorded during the test run 

Charts Provides a graphical display of the individual results data 

Test Summary Provides a summary of the settings used for the test run 

 
LŦ ǘƘŜ {ǘŀǘǳǎ ƛǎ ƴƻǘ ά¢Ŝǎǘ ŎƻƳǇƭŜǘŜŘ ǿƛǘƘ ƴƻ ŜǊǊƻǊǎέ ƻǇŜƴ ǘƘŜ Event Log tab to check the errors. 
Remove the cause of the errors and re-run the test.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 


























































































